Sunday, 30 May 2010

Issue indexing pages containing the Search Core Results Web Part in SharePoint 2010

I have spotted an issue with search on SharePoint 2010 when it tries to index a page containing the Search Core Results Web Part, which I am using in particular pages on a site to rollup content across an entire Web Application. When it tries to index one of these pages, the following message appears: "The SharePoint item being crawled returned an error when attempting to download the item”.

Usually, Search Center sites are created with the <noindex> attribute enabled, so you don't normally see this behaviour as the search results pages containing the Web Part are not normally indexed.​ You can choose an option in the crawl logs to prevent the page being indexed in the future, and it appears that this issue does not prevent the rest of the site from being indexed as long as the Search Core Results Web Part is not used on the home page of the site - I have noticed it can stop the whole site from bring indexed if it is.

11 comments:

  1. If I use default people search results web part on home page,I am seeing this error that my site is not getting crawled..can I choose an option in the crawl logs to prevent this home page being indexed in the future????If so how?

    ReplyDelete
  2. This problem is fixed with Juni Search Hotfixes for Sharepoint Server. We have the same problems and build a control (workaround) for it , but the Hotfix solved this problem.

    ReplyDelete
  3. Can you give the url for the hotfix you applied? Thanks

    ReplyDelete